PDA

查看完整版本 : 一个读取rockey加密狗内容的小工具


qdcrack
2004-12-03, 15:34:30
以前做的东西,不是很完善,很多东西没做完,大家用得着的就看看吧!
(易语言做的,可能有些杀毒软件会报毒,不过肯定没有的,大家放心)
http://www.qdcrack.com/rockeyreader.rar

采臣·宁
2004-12-03, 15:35:38
不错不错,E语言也这么熟

hhtcb
2004-12-03, 15:46:31
楼主,你的工具还要输入基本密码,怎么知道密码呢?
有读取密码的工具吗?

qdcrack
2004-12-03, 15:49:41
基本密码是不可能通过加密狗获取的,需要用到rockey加密的软件,因为rockey的加密狗密码比较好找,
反编译程序,然后查找“rockey”字样,看上面的调用,找到一个
push 00000001
call ********
的这个调用,就是打开加密狗,然后往上看,应该很快找到加密狗密码!找不到的话发程序给我,我帮你看看!

hhtcb
2004-12-03, 15:53:51
有好多的 push 00001和call XXXXXXXX
给我看一下吧!附件:GYSHB.rar (bbs.pediy.com/upload/file/2004/12/GYSHB.rar_428.rar) 附件:GYSHB.rar (bbs.pediy.com/upload/file/2004/12/GYSHB.rar_428.rar)

qdcrack
2004-12-03, 16:06:11
1:70EF
2:BF70
你这个是外壳加密,不一样的!

hhtcb
2004-12-03, 16:08:39
老兄,谢谢!我试一下!

hhtcb
2004-12-03, 16:12:11
你可以帮我看一个Rockey4的程序吗?壳我已经脱了,但是还是进入主界面后会提示插入合法的版权锁,程序比较大有8.72M!

qdcrack
2004-12-03, 16:14:34
150025153

hhtcb
2004-12-03, 16:21:04
好的!我先谢谢了!你好象不在线啊!文件我已经发在QQ上了!

hhtcb
2004-12-03, 16:31:47
读取狗的数据能做成模拟狗吗?

roby
2004-12-03, 16:48:29
e语言写的?
敬佩
最近正在研究这个
如果 能share下你的代码就感激了

采臣·宁
2004-12-03, 16:49:13
E语言不容易逆向。

qdcrack
2004-12-03, 16:57:33
这个还只是读取数据参考,做模拟狗的必备东西而已!

采臣·宁
2004-12-03, 17:19:12
这个还只是一部分????

hhtcb
2004-12-03, 17:20:21
qdcrack 老兄,能帮我看程序吗?

deanlh
2004-12-03, 17:21:52
顶,易语言不错呀。。。。。。。。。。。

hhtcb
2004-12-04, 08:55:40
是啊!程序太大,看得都晕了!

lihai3330
2004-12-04, 21:51:51
老兄,为什么是演示板,有什么限制吗??

13521110000
2004-12-05, 19:55:52
帮我看看这个软件附件:readdog.rar (bbs.pediy.com/upload/file/2004/12/readdog.rar_605.rar)

13521110000
2004-12-06, 20:09:05
老大帮忙看下!!

PCWE
2005-12-21, 21:26:31
楼主,你的工具载不了啊!!

海笑
2006-01-05, 00:32:08
谢了:eek:

lei_z_r
2006-01-05, 02:30:53
哈,这个工具不错啊,什么时候放出你的模拟狗程序给大家啊:3: :3: :3:

xiong779
2006-01-05, 12:41:08
看到E遮言不容易反??的?,,得??一下

无名人
2006-01-06, 05:53:25
楼主,你的工具载不了啊!!

matali
2006-01-06, 06:42:54
最初由 无名人 发布
楼主,你的工具载不了啊!!

sickman
2006-01-11, 22:32:04
最初由 无名人 发布
楼主,你的工具载不了啊!! 你的网站也上不去

科维
2006-01-18, 14:01:37
看看,学习学习

killes
2006-01-19, 03:28:45
我晕,居然无法下载的东西都放在这里?

brainli
2006-02-28, 01:26:21
照例程写了段读ROCKEY的,可是读用户区的时候数据读出是错误的,有E达人看看吗?
.版本 2

.程序集 窗口程序集1

.子程序 _读用户内存_被单击
.局部变量 文本变量, 文本型

' a = Rockey_查找锁 (pwd1, pwd2, pwd3, pwd4)
' 测试 (a = lp1)
' 加密锁句柄 = Rockey_打开锁 (pwd1, pwd2, pwd3, pwd4, a, b)
信息框 (“已打开加密锁,句柄为:” + 到文本 (加密锁句柄), 0, )
bin = Rockey_读锁 (加密锁句柄, 0, 32)
用户数据 = bin
信息框 (用户数据, 0, )
用户内存编辑框asiic.内容 = 到文本 (bin)
文本变量 = 取十六进制文本 (到长整数 (bin))
用户内存编辑框16H.内容 = 文本变量

.子程序 _打开锁_被单击
.局部变量 局部变量s, 文本型


.如果真 (Rockey_取错误码 () ≠ 0)
信息框 (“加密锁打开失败!”, 0, )
.如果真结束
.如果 (retcode = 0)
加密狗ID号.内容 = 到文本 (lp1)
加密锁硬件ID = lp1
信息框 (“已打开加密锁,句柄为:” + 到文本 (加密锁句柄), 0, )
信息框 (“发现加Rockey密狗,其硬件ID为:” + 到文本 (lp1) + “。”, 0, )
bin = Rockey_读锁 (加密锁句柄, 0, 15)
用户内存编辑框asiic.内容 = 到文本 (bin)
用户内存编辑框16H.内容 = 取十六进制文本 (到长整数 (bin))
Rockey_打开锁 (p1, p2, p3, p4, 加密锁硬件ID, 加密锁类型)
锁类型.标题 = 到文本 (加密锁类型)
a = Rockey_读用户ID (加密锁句柄)
用户ID.内容 = 到文本 (a)
.否则
信息框 (“没有发现Rockey加密狗!”, 0, )

返回 ()
.如果结束






.子程序 __启动窗口_创建完毕

' 本段代码只是作为模块内部测试使用,所用密码为Rockey测试组件中的的公开密码

' 信息框 (基本密码1.内容 + “|” + 基本密码2.内容 + “|” + 高级密码1.内容 + “|” + 高级密码2.内容, 0, )


'这里的编辑框控件的内容要大小写转化才行(小写>大写),另外密码输入框中的16进制文本要转化为10进制的数值,转化的子程序(十六转十)写在后面的.
pwd1 = 到整数 (十六转十 (基本密码1.内容)) ' cb0c
pwd2 = 到整数 (十六转十 (基本密码2.内容)) ' c4f4
pwd3 = 到整数 (十六转十 (高级密码1.内容)) ' c42b
pwd4 = 到整数 (十六转十 (高级密码2.内容)) ' f7fb

'信息框 (到文本 (pwd1) + “|” + 到文本 (pwd2) + “|” + 到文本 (pwd3) + “|” + 到文本 (pwd4), 0, )

p1 = pwd1
p2 = pwd2
p3 = pwd3
p4 = pwd4



function = #RY_FIND
' 一个Rockey()函数即可完成所有功能
retcode = Rockey (function, handle, lp1, lp2, p1, p2, p3, p4, buffer)

a = Rockey_查找锁 (pwd1, pwd2, pwd3, pwd4)
' 测试 (a = lp1)
加密锁句柄 = Rockey_打开锁 (pwd1, pwd2, pwd3, pwd4, a, b)


.子程序 _加密狗ID号_内容被改变



.子程序 _读用户ID_被单击


Rockey_打开锁 (p1, p2, p3, p4, 加密锁硬件ID, 加密锁类型)
锁类型.标题 = 到文本 (加密锁类型)
a = Rockey_读用户ID (加密锁句柄)
用户ID.内容 = 到文本 (a)


.子程序 文本变量





.子程序 十六转十, 文本型
.参数 待转数值, 文本型
.局部变量 n1, 整数型
.局部变量 w1, 整数型
.局部变量 返回值, 文本型
.局部变量 余值, 文本型
.局部变量 累计, 整数型

n1 = 取文本长度 (待转数值)
.计次循环首 (n1, w1)
余值 = 取文本中间 (待转数值, w1, 1)
.判断开始 (余值 = “A”)
余值 = “10”
.判断 (余值 = “B”)
余值 = “11”
.判断 (余值 = “C”)
余值 = “12”
.判断 (余值 = “D”)
余值 = “13”
.判断 (余值 = “E”)
余值 = “14”
.判断 (余值 = “F”)
余值 = “15”
.默认

.判断结束
累计 = 累计 + 到数值 (余值) × 求次方 (16, n1 - w1)
.计次循环尾 ()
返回值 = 到文本 (累计)
返回 (返回值)



.子程序 测试, , , 参数“执行结果”为真表示测试成功,否则表示测试失败。
.参数 执行结果, 逻辑型

.如果 (执行结果 = 真)
输出调试文本 (“测试成功”)
.否则
输出调试文本 (“测试失败!!!”)
输出调试文本 (“---- 错误码:” + 到文本 (Rockey_取错误码 ()) + “;错误文本:” + Rockey_取错误文本 ())
鸣叫 () ' 用作提醒
暂停 () ' 以便于定位错误代码行,按F8
.如果结束