首页
论坛
专栏
课程

[[Disassemblers]] [分享]Ida Pro 6.5 with Hex-Rays x86 Decompiler v1.5 and Hex-Rays arm Decompiler 1.7

2014-8-21 16:13 6366

[[Disassemblers]] [分享]Ida Pro 6.5 with Hex-Rays x86 Decompiler v1.5 and Hex-Rays arm Decompiler 1.7

obaby
18
2014-8-21 16:13
6366
整合了一下两个F5插件,其中x86的F5插件来自6.1版本的IDA,arm版的F5插件是从6.3版本的IDA中破解移植过来的,目前我自己测试OK,如果大家有神马问题可以在这里反馈。如果不使用我修改后的版本只移植插件的话会在加载的时候提示找不到正确的授权文件,但是不影响F5功能的使用。
版本信息:


ArmF5效果:


版本信息:


X86F5效果:

版本信息:


猛击后面的链接下载:http://pan.baidu.com/s/1gd3lXtD

单纯插件,arm是1.7,x86还是1.5.~
http://pan.baidu.com/s/1bnCNAdL

[推荐]看雪企服平台,提供安全分析、定制项目开发、APP等级保护、渗透测试等安全服务!

上传的附件:
上一主题 下一主题
最新回复 (36)
jstqyymwy 2014-8-21 16:19
2
0
还是这个修改版不错,thanks for share
proteas 2 2014-8-21 16:23
3
0
今天跟过年似的。。。
netsniffer 2014-8-21 16:24
4
0
! NiuBi  !
rrrfff 2014-8-21 16:35
5
0
linhanshi 2014-8-21 16:43
6
0

shuxuliang 2014-8-21 17:25
7
0
need  Hex-Rays x64 Decompiler
obaby 18 2014-8-21 17:26
8
0
木有
linhanshi 2014-8-21 17:30
9
0
這要求都很高啊 有用的 就可以了
obaby 18 2014-8-21 17:31
10
0
都喜欢新版本,但是一个都木有
dolphinzhu 2014-8-21 17:37
11
0
http://www.52pojie.cn/thread-286036-1-1.html
这个网页中截图中两个1.7版本的插件,包括X86和ARM,他们是怎么弄的??
obaby 18 2014-8-21 17:39
12
0
原来有更新的了,都没注意。折腾了一个旧版的~
1.7之后的插件和以前的插件变化较大,我上面的有个是比较旧的,所以只显示了一个。
yulinxie 2014-8-21 17:44
13
0
hexarm1.7.zip 这个里面的hexryas.plw还是1.5版本的。
linhanshi 2014-8-21 17:50
14
0
這真無語了
obaby 18 2014-8-21 17:56
15
0
发现了,但是截图里面是1.7的。有个没发出来
goddkiller 2014-8-21 18:35
16
0
52那边的人素质真高,把EXETOOLS上人家发的图发到他们那里,然后N多小白问为啥没有1.7的X86。

那个图是EXETOOLS上的一个会员调试HEXARM.PLW显示出来的,就算改了也不能用,一用就CRASH,因为

KEY里面要校验对应的X86的1.7那个版本,而泄漏出来的只是ARM的1.7.。。x86的1.7貌似没放出来
dolphinzhu 2014-8-21 18:38
17
0
我也正纳闷呢, 为什么我自己的显示和他们的截图不同。

多谢解答!

楼主分享的这个单纯插件,使用起来有问题! X86插件会挂掉!见附图。
http://pan.baidu.com/s/1bnCNAdL

我的环境是win7  64位,安装原版的IDA Pro6.5.
上传的附件:
netsniffer 2014-8-21 20:09
18
0
android4.4 上 debug 可执行文件 总提示 input file is a dynamic ...,这个支持吗?
atompure 2014-8-21 20:12
19
0
把cfg文件夹中的hexrays.cfg文件删除再打开就不会出现这个问题了
FlashK 2014-8-21 21:55
20
0
看图x32的才是1.5吧?
ellee 2014-8-21 22:02
21
0
把97行注释掉就不会有问题了
dolphinzhu 2014-8-21 22:18
22
0
注释了,就OK了!
多谢指导!!!
房有亮 3 2014-8-21 23:00
23
0
单纯插件,x86是1.7,arm还是1.5.~
http://pan.baidu.com/s/1bnCNAdL

LZ 写错了吧,X86 1.5 ARM 1.7
房有亮 3 2014-8-21 23:26
24
0
惭愧,从没搞过 安卓,我反汇编了一个 .so文件 才发现 F5好用,看了网上的介绍一只以为 是 dex 文件
obaby 18 2014-8-22 09:31
25
0
是写错鸟~
XPoy 3 2014-8-23 12:02
26
0
我只能说,你是个好人
wem 2014-8-26 21:01
27
0
谢谢分享
booz 2014-9-12 11:37
28
0
好东西必须支持啊~~ 太感人了~~~
FlashK 2014-9-12 20:57
29
0
1.8 ARM插件出了么?
oep1 4 2014-9-14 18:33
30
0
偷偷的下载了下,支持
ywqjwq 2014-9-14 21:51
31
0
thanks
木桩 8 2014-11-4 14:44
32
0
找macos版的IDA发现这个,arm的F5插件寻觅好久了。感谢分享!
gotope 2014-12-6 22:36
33
0
这个idaq64.exe报错,fatal error before kernel init??
OS: WIN7 X64

感谢
zjjhszs 2014-12-6 22:37
34
0
速度收下  度娘又要抽风了
obaby 18 2014-12-8 10:44
35
0
集成的插件Bindiff 的64位插件有问题导致的,和ida本身没有关系,删除或者重命名插件目录下的zynamics_bindiff_8.p64就可以了。
gotope 2014-12-8 18:06
36
0
删掉了zynamics_bindiff还不行, 然后又删了一个zynamics_binexport_8 就好了
chixiaojie 2014-12-12 10:30
37
0
这是什么高级货,整的这么复杂,小菜表示完全不懂。
游客
登录 | 注册 方可回帖
返回