首页
论坛
专栏
课程

[求助]frida-ps -U报错,求解,谢谢!!

wx_阿宽 2018-8-8 00:42 2219
C:\Users\Administrator>frida-ps -U

***
Failed to load the Frida native extension: DLL load failed: 找不到指定的模块。
Please ensure that the extension was compiled for Python 3.x.
***

Traceback (most recent call last):
  File "D:\Python37\Scripts\frida-ps-script.py", line 11, in <module>
    load_entry_point('frida-tools==1.1.0', 'console_scripts', 'frida-ps')()
  File "d:\python37\lib\site-packages\frida_tools\ps.py", line 6, in main
    from frida_tools.application import ConsoleApplication
  File "d:\python37\lib\site-packages\frida_tools\application.py", line 19, in <
module>
    import frida
  File "d:\python37\lib\site-packages\frida\__init__.py", line 24, in <module>
    raise ex
  File "d:\python37\lib\site-packages\frida\__init__.py", line 7, in <module>
    import _frida
ImportError: DLL load failed: 找不到指定的模块。
运行frida-ps -U就报错,手机端已经运行,卡在这里了,求解!!!!谢谢!!
D:\>adb push frida-server /data/local/tmp
frida-server: 1 file pushed. 12.6 MB/s (38059880 bytes in 2.873s)
D:\>adb shell
ugglite:/ $ su
ugglite:/ # cd /data/local/tmp
ugglite:/data/local/tmp # ls
\aapt2 box2 drizzleDumper frida-server mtools2
ugglite:/data/local/tmp # ls
aapt2 box2 drizzleDumper frida-server mtools2
ugglite:/data/local/tmp # chmod 777 frida-server
ugglite:/data/local/tmp # ./frida-server



[推荐]看雪企服平台,提供APP等级保护加固等安全服务!

最新回复 (9)
ctw爱情 2018-8-9 11:48
2

0

我的也是这样 你的是什么手机 安装的py是什么版本?我的是12.0.8 手机6.0
wx_阿宽 2018-8-9 21:33
3

0

ctw爱情 我的也是这样 你的是什么手机 安装的py是什么版本?我的是12.0.8 手机6.0
我是小米NOTA5A  也是12.0.8   手机7.1.2
ctw爱情 2018-8-9 21:46
4

0

wx_阿宽 我是小米NOTA5A 也是12.0.8 手机7.1.2
我解决了 重新下载个py3.6.6 重新安装 配置好环境就好了
wx_阿宽 2018-8-12 21:38
5

1

ctw爱情 我解决了 重新下载个py3.6.6 重新安装 配置好环境就好了
谢谢 我也试试
leaderzhang 2018-12-4 12:28
6

0

请问解决了吗

endlif 1 2018-12-4 15:16
7

0

我换了好多个版本依然未解决这个问题
kkang 4天前
8

0

出现同样的问题 请问怎么解决???
xswakx 3天前
9

0

frida的版本和python的版本不匹配
xswakx 3天前
10

0

看你的python版本是37的要用frida 12.2.27版本cmd    pip   list看版本号
返回