首页
论坛
课程
招聘
【已解决】如何解决tmux和pwndbg的兼容问题? | 如何在docker中gdb.attach?
2018-11-1 21:21 5776

【已解决】如何解决tmux和pwndbg的兼容问题? | 如何在docker中gdb.attach?

2018-11-1 21:21
5776
最近在docker中做pwn,为了使用pwntools的gdb.attach,需要开一个tmux,exp中设置,context.terminal = ['tmux', 'splitw', '-h' ],这样才可以出现一个新的终端。

问题在于tmux和pwndbg的兼容问题:
在非tmux下使用pwndbg时,一切正常。
在tmux下使用pwndbg时,会出现乱码的问题。

请问如何解决pwndbg和tmux的兼容问题,或者在不用tmux的情况下让gdb.attach时新弹一个终端呢?



[培训]12月3日2020京麒网络安全大会《物联网安全攻防实战》训练营,正在火热报名中!地点:北京 · 新云南皇冠假日酒店

最后于 2018-11-2 12:53 被心许雪编辑 ,原因:
收藏
点赞1
打赏
分享
最新回复 (1)
雪    币: 4343
活跃值: 活跃值 (43)
能力值: ( LV10,RANK:160 )
在线值:
发帖
回帖
粉丝
心许雪 活跃值 3 2018-11-2 12:52
2
1
已经解决,升级tmux版本到2.6+即可。
游客
登录 | 注册 方可回帖
返回