首页
论坛
专栏
课程

[原创]在 VS2017 使用所有旧版本的平台工具集

2019-1-7 00:33 2592

[原创]在 VS2017 使用所有旧版本的平台工具集

2019-1-7 00:33
2592

用 VS2017 写代码, 用 VC++6.0 编译.

本文环境

  • Windows 10 x64
  • VS2017
  • VS2010
  • VC++6.0

具体流程

  • 安装 VS2017

    注意要把核心的那些组件都勾选, 经常看到有朋友为了节约硬盘空间少勾选导致功能缺失.

  • 安装 VS2010, 这一步必需, 因为 daffodil 依赖它.

  • 安装 VC++6.0

    关于 VC++6.0 在 Windows 10 上的安装有很多注意事项, 将在下面截图说明.

  • 安装 daffodil, 这是网上下载的二进制文件(SHA1: 2607551296479c289c17575c51327f5a19dd5150), 同时它也是个开源的项目, 源码在这里.

  • 如果一切顺利, 这个时候用 VS2017 新建项目就可以在 项目属性 - 平台工具集 中切换了.

安装VC++6.0

想要使用 VC++6.0 的主程序, 就应该安装英文版, 中文版会闪退, 不过只是 IDE 闪退, 并不影响本文中提到的编译环节.

 

 

 

 

 

 

 

 

 

注意事项

  • 切换平台工具集之后, 它需要一点时间重新扫描和组织项目, 左下角显示就绪的时候就可以开始尝试编译了.

  • 这和 v141_xp 这样的平台工具集不同, 这是完全地切换了编译器、链接器、SDK, 所以你必须要符合原先的代码, 换句话说, vs2017 只是为你提供了先进舒适的编码体验, 代码还是要按照旧的平台工具集来写. 例如用 v60 的时候, 就不能用中文命名变量, 因为 VC++6.0 只支持 ANSI 编码的源文件.

推荐个神器



[推荐]看雪企服平台,提供安全分析、定制项目开发、APP等级保护、渗透测试等安全服务!

最后于 2019-1-7 01:03 被junkboy编辑 ,原因: add sha1
上传的附件:
上一主题 下一主题
打赏 + 5.00
打赏次数 1 金额 + 5.00
收起 
赞赏  amzilun   +5.00 2019/01/08
最新回复 (12)
keyuan 2019-1-7 00:36
2
2
悄悄地顶一下JB
流星暴雨 2019-1-7 00:37
3
2
支持一下
靴子 2019-1-7 09:56
4
1
mark~
layerfsd 4 2019-1-7 10:05
5
1
支持一下vc6,好多年不用vc6,以前写代码还非vc6不行
wanttobeno 2019-1-7 10:26
6
1
小番茄VS必装插件
xie风腾 2019-1-7 10:34
7
1

多谢楼主分享哟
KevinsBobo 4 2019-1-7 13:35
8
0
很赞呀
yeyeshun 2 2019-1-8 10:21
9
1
顺路推广一下我之前做的类似的工具:
https://bbs.pediy.com/thread-222495.htm
我是把vs2013的工程做一个转换,编译时使用了vc6的SDK。
shayi 8 2019-1-8 13:05
10
0
很NB,赞一个
windxiang 2019-1-8 14:41
11
0
很NB很赞呀
amzilun 2 2019-1-8 23:15
12
0
好帖,赞一个
diasstudy 2019-1-9 08:10
13
0
全部都安装,那得要多少空间啊
游客
登录 | 注册 方可回帖
返回