首页
论坛
课程
招聘
[求助]在本站下的IDA5.2在调试exe时常常会出错,各位有没有遇到过这样的情况?
2008-4-24 11:16 5744

[求助]在本站下的IDA5.2在调试exe时常常会出错,各位有没有遇到过这样的情况?

bpx 活跃值
3
2008-4-24 11:16
5744
出错信息为:
Access violation at address 00412D9F in module "idag.exe" Read of address 00000000

偶尔又不会出错。

由于在IDA中边调试可以边修改函数名和添加注释,所以我从不用OllDbg. 这样出错害得我不得不用回旧版的IDA。有没有什么办法可以对付过去?

[2022冬季班]《安卓高级研修班(网课)》月薪三万班招生中~

收藏
点赞0
打赏
分享
最新回复 (7)
雪    币: 201
活跃值: 活跃值 (11)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
BeQuick 活跃值 2008-4-24 14:11
2
0
这是调试器版本的问题 看雪上提供的IDA5.2内置的是WinCE 5.0 Debugger (当然这也可能是WinCE 5.0 Debugger 自身的问题)

你可以下载IDA 5.1,其附带的调试器版本为WinCE 5.1 Debugger,不会出现以上问题。
雪    币: 204
活跃值: 活跃值 (10)
能力值: ( LV8,RANK:130 )
在线值:
发帖
回帖
粉丝
bpx 活跃值 3 2008-4-24 15:36
3
0
谢谢回复。

那就比较奇怪了,为何5.2内置的是WinCE 5.0 Debugger 而5.1的调试器反而更新?难道5.2是我们自己拼凑出来的?另外,好像这里没有5.1可下,哪里有呢?我可不可以将5.1的debugger放在5.2中?
雪    币: 201
活跃值: 活跃值 (11)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
BeQuick 活跃值 2008-4-24 18:15
4
0
你可以双击 IDA安装目录下的 unins000.exe(并不是要卸载,而是可以看到IDA 以及调试器版本的信息)

至于看雪提供的IDA5.2为什么内置WinCE 5.0 Debugger ,我也不知道为什么

我这里有IDA 5.1以及相应的Debugger

我的理解:调试器是一个插件,所以可以只要将相应的插件拷贝到plugin目录下就可以了。不过这只是猜测,你可以试一试,看将5.1的调试器插件拷贝到5.2中能否工作
雪    币: 201
活跃值: 活跃值 (11)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
BeQuick 活跃值 2008-4-24 18:18
5
0
ida 5.1及相应的Debugger应该可以在网上找得到
雪    币: 200
活跃值: 活跃值 (10)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
skyist 活跃值 2008-8-12 10:45
6
0
貌似"debugger"->"switch debugger"->"local windows debugger"就可以了
雪    币: 239
活跃值: 活跃值 (10)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
starmate 活跃值 2009-8-6 19:15
7
0
最近调试也发现了这个问题,有谁可以解决吗?另外调试器的插件怎么查找呢?我不知道调试器插件是哪个。。。
雪    币: 239
活跃值: 活跃值 (10)
能力值: ( LV2,RANK:10 )
在线值:
发帖
回帖
粉丝
starmate 活跃值 2009-8-6 19:31
8
0
解决问题了,直接运行调试器就可以了,如果已经反编译过,选择加载,就可以调试了,可能是IDA的问题吧
游客
登录 | 注册 方可回帖
返回